你好,游客 登录
背景:
阅读新闻

Scala报错:Exception in thread “main” java.lang.UnsupportedClassVersionError

[日期:2018-09-15] 来源:csdn  作者:papamilk [字体: ]

cmd中运行scala,出现错误提示:Exception in thread "main" java.lang.UnsupportedClassVersionError: scala/tools/nsc/MainGenericRunner : Unsupported major.minor version 52.0

可能原因:猜测是JDK版本不兼容的原因

解决办法一:卸载jdk1.7,安装jdk1.8

解决办法二:卸载高版本的scala,换成低版本的scala

最后,我选择换成低版本的scala。这时,运行scala就没有问题了。

 

收藏 推荐 打印 | 阅读: